outage on donate.worldvision.org

Incident Report for World Vision U.S.

Resolved

The primary donate site instance is back online, and we have switched back from the failover instance. Our webhost is investigating the root cause and will provide an RCA. All systems are operational.
Posted Nov 15, 2025 - 21:16 PST

Monitoring

We have switched to our donate failover, which is working properly, and the donate site is back online and processing orders. Still determining RCA of the original outage.
Posted Nov 15, 2025 - 20:36 PST

Investigating

donate.worldvision.org is down. Authentication may also be effected. IBU Support is investigating
Posted Nov 15, 2025 - 19:59 PST
This incident affected: My World Vision (My World Vision), Donate (eCommerce, Check Out), and Text To Sponsor.