donate site is down

Incident Report for World Vision U.S.

Resolved

the primary donate site has stabilized, and we have switched back to our primary host for the night.
Posted Nov 16, 2025 - 20:45 PST

Identified

We have failed over to our backup site. Donate site is working once again on the backup host.
Posted Nov 16, 2025 - 20:00 PST

Investigating

donate site is once again experiencing performance issues. Support is investigating
Posted Nov 16, 2025 - 19:52 PST
This incident affected: My World Vision (My World Vision), Donate (eCommerce, Check Out), and Text To Sponsor.