Instability in various World Vision Sites

Incident Report for World Vision U.S.

Resolved

Cloudflare has resolved the issues with their infrastructure, and World Vision sites are functional once again.
Posted Nov 18, 2025 - 07:11 PST

Monitoring

Cloudflare continues to work on a fix for their Global Network. World Vision sites are seeing an increased impact from this outage.
Posted Nov 18, 2025 - 06:08 PST

Identified

Various World Vision sites (WWW/Donate/MYWV) are showing instability, with some slow loads and connection failures. This is due to issues with Cloudflare, their global network is experiencing issues.
Posted Nov 18, 2025 - 05:11 PST
This incident affected: My World Vision (My World Vision), Donate (eCommerce, Check Out), and Sponsorable Child Requests, WWW Content, Text To Sponsor, Login Page.