Login is down

Incident Report for World Vision U.S.

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 15:04 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 13:48 PST

Investigating

We are currently investigating this issue.
Posted Jan 27, 2026 - 12:15 PST

Monitoring

Systems appear to be back to normal - we will continue to monitor
Posted Jan 27, 2026 - 11:21 PST

Investigating

We are currently investigating this issue.
Posted Jan 27, 2026 - 10:35 PST
This incident affected: My World Vision (My World Vision, My World Vision Mobile App), Donate (Check Out), and Login Page.