wvus.link and wv.link down

Incident Report for World Vision U.S.

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 01:36 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 16:00 PDT

Investigating

We are currently investigating this issue.
Posted Mar 13, 2026 - 15:20 PDT