Slow authentication, partial My World Vision outage

Incident Report for World Vision U.S.

Resolved

This incident has been resolved.
Posted Aug 03, 2025 - 16:33 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 03, 2025 - 16:32 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2025 - 16:32 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 03, 2025 - 16:03 PDT

Identified

The issue has been identified and a fix is being determined.
Posted Aug 03, 2025 - 15:59 PDT

Investigating

We are currently investigating this issue.
Posted Aug 03, 2025 - 15:48 PDT
This incident affected: My World Vision (My World Vision) and Login Page.