Distributed site slowness

Incident Report for World Vision U.S.

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 15:30 PDT

Update

This appears to be an issue with one of our infrastructure providers
Posted Oct 29, 2025 - 12:42 PDT

Investigating

Login process is slow, potentially only on certain regions. Our team is investigating the scope of the issue.
Posted Oct 29, 2025 - 09:13 PDT
This incident affected: My World Vision (My World Vision) and WWW Content, Login Page.